Autor Thema: Navigation Menu Items Not Functioning on Index Page  (Gelesen 548 mal)

Ben Ipinge

  • Gast
Good day,

We upgraded to the latest available KIX4OTRS 8.0.12 running on OTRS 5.0.17 & KIXCore 5.0.11, the upgrade went well. However, when you login and click on any item on the navigation menu it doesn't work. You need to manually enter the url to navigate, then only will you be able to use navigation menu item.

And when you go back to the dashboard, the navigation menu items still do not work and the dropdown items are displayed behind the dashlets.

How can we resolve with without breaking compatability?

Regards,

Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #1 am: 02.06.2017 07:56:20 »
Hi Ben,

its difficult to say, whats going wrong.

Please send me a Screenshot of the „Package Manager“. Futhermore I need an excerpt of the
OTRS-Log and Apache-Error-Log. (Last 100 entrys)

Regards,
Rico Ullmann

Ben

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #2 am: 14.06.2017 12:33:41 »
Good day,

I need to register so that I can attach files. However the verification option does not show, so I cannot register.

Can you assist with my registration?

Regards,

Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #3 am: 14.06.2017 12:52:06 »
Hi Ben,

i have tested the registration process and it works for me. Also the captcha dialog was showing.

Perhaps you shoud delete your cache and try it again or change browser.

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #4 am: 14.06.2017 16:37:18 »
Good day Rico,

Here are the attachments as requested.

The error log is for today's work.

I started by trying to resolve the package issues which where not compatible with OTRS 5 by manually installing the missing files. However that didn't work so I had to uninstall all the OTRS 4 version only packages.

Regards,

Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #5 am: 15.06.2017 09:07:32 »
Hi Ben,

after upgrade, did you delete cache and rebuild the config?

Path: <OTRS-Path>/bin

sudo -u www-data ./otrs.Console.pl Maint::Cache::Delete
sudo -u www-data ./otrs.Console.pl Maint::Config::Rebuild

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #6 am: 15.06.2017 09:42:37 »
Hi Rico,

Almost after every change.

Regards,

Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #7 am: 15.06.2017 10:10:22 »
Which was your KIX4OTRS version before you decided to upgrade?

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #8 am: 15.06.2017 10:49:50 »
Rico,

We upgraded from 4.0.22 to 5.0.17 before now updating to 5.0.19

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #9 am: 15.06.2017 15:37:37 »
Rico,

Are you part of the Cape IT/KIX team?

Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #10 am: 16.06.2017 09:29:13 »
Hi Ben,

yes, this is correct.

In your error_log are a lot of permisson issues.

Can you describe me step by step what you did?

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #11 am: 16.06.2017 09:49:36 »
Hi Rico,

When I upgraded from 4 to 5, I used instructions here: http://doc.otrs.com/doc/manual/admin/5.0/en/html/upgrading.html

When I upgraded from 5.0.17 to 5.0.19, I used the instructions here: http://doc.otrs.com/doc/manual/admin/6.0/en/html/upgrading.html

After upgrading or installing packages I run this sequence of commands under /opt directory:
otrs/bin/otrs.SetPermissions.pl --web-group=www-data
su -c "otrs/bin/otrs.Console.pl Maint::Config::Rebuild" -s /bin/bash otrs
su -c "otrs/bin/otrs.Console.pl Maint::Cache::Delete" -s /bin/bash otrs

Regards,


Rico Ullmann

  • Newbie
  • Beiträge: 53
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #12 am: 16.06.2017 10:54:25 »
Hi Ben,

you started with OTRS 4.0.22 and KIX4OTRS 7.1.x??

Regards

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #13 am: 16.06.2017 10:59:32 »
Yep

BenI

  • Newbie
  • Beiträge: 20
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #14 am: 16.06.2017 12:11:33 »
By the way, we also have developed our brand skin that we are applying but it doesn't seem that its the problem.

With KIX4OTRS installed, when I try to open a ticket I get the following error message which is not present when KIX4OTRS is uninstalled.
[error] Can't use string ("2") as a HASH ref while "strict refs" in use at /opt/otrs/KIX4OTRS/Kernel/Modules/AgentTicketZoom.pm line 946.\n[\code]