Autor Thema: Navigation Menu Items Not Functioning on Index Page  (Gelesen 5307 mal)

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #15 am: 16.06.2017 18:00:49 »
Rico,

Today, I uninstalled KIX4OTRS and KIXCore. I could access the tickets again but the dashboard navigation menu links still didn't work. Dropdown options are also not popping up.

I have reinstalled them subsequently and everything remains as it was.

Attached is the error log for the day.

Your assistance is highly appreciated.

Regards,

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #16 am: 18.06.2017 15:58:00 »
Hi Rico,

Is there perhaps a way to start from scratch and just restore the necessary data such as queues, agents, dynamic fields, ITSM or CMDB, etc..?

Regards,

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #17 am: 19.06.2017 08:56:21 »
Hi Ben,

you can dump your data with script "backup.pl" located in "<OTRS-PATH>/scripts".

Example:

./backup.pl -d /tmp

You can restore your database-data with "restore.pl".

Example:

./restore.pl -b /tmp/2017-06-19_08-15/ -d /opt/otrs-5.0.17

If you only wish to restore your database entries, then delete "Applicaton.tar.gz" and "Config.tar.gz", which were build during backup.

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #18 am: 19.06.2017 09:37:19 »
Hi Rico,

Thanks. Do you think this will be able to resolve these issues? and the backup will only restore the data right?

Regards,

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #19 am: 19.06.2017 10:47:46 »
Hi Ben,

i hope so.

Backup your old otrs-directory. Use an new database name for your new installation. If the installation fails, we can go back to your present system.

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #20 am: 19.06.2017 15:02:22 »
Rico,

What is contained in application.tar.gz and config.tar.gz?

Regards,

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #21 am: 19.06.2017 15:45:27 »
Hi Ben,

Config.tar.gz contained all config files below directory "Kernel".

Application.tar.gz includes all files of your OTRS and KIX4OTRS application.

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #22 am: 19.06.2017 17:42:49 »
Hi Rico,

Some progress made today.

I started from scratch. Restored the database only. Reinstalled all the packages including KIXCore and KIX4OTRS.

The data is restored. The NVD3 error is gone. The navigation menu issue is resolved as well and dropdown items are popping out again.

We now have 1 error that occurs when I try to open an old ticket.
[Mon Jun 19 16:41:03 2017] [error] Can't use string ("2") as a HASH ref while "strict refs" in use at /opt/otrs/KIX4OTRS/Kernel/Modules/AgentTicketZoom.pm line 946.\n
Restarting the server didn't work. What might be the cause with this error?

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #23 am: 20.06.2017 07:57:45 »
Hi Ben,

if you installed OTRS 5.0.19 then you need the following packages for KIX4OTRS:

1. OTRS::ITSM => 5.0.19
2. KIXCore => 5.0.12
3. KIX4OTRS => 8.0.13

Have these modules been installed?

Regards,
Rico Ullmann

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #24 am: 20.06.2017 09:12:30 »
Hi Rico,

Yep. All the modules have been installed.

Regards,

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #25 am: 20.06.2017 09:46:07 »
Ok.

New tickets do not cause problems?

Regards

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #26 am: 20.06.2017 10:42:11 »
Rico,

Seems that they are causing problems as well.

I managed to create a ticket, however it is not showing up on the new ticket dashlet. Here is the error message:
Message: No such ConfigItemID (ben.ipinge)!

 RemoteAddress: 192.168.229.113
 RequestURI: /index.pl?Action=AgentTicketZoom;TicketID=190;OTRSAgentInterface=1j3h6sCfNRxKOlr1f0Nr0jWDHyXCz937

 Traceback (7627):
   Module: Kernel::System::ITSMConfigItem::ConfigItemGet Line: 339
   Module: Kernel::System::ITSMConfigItem::XML::Type::CIClassReference::ExportSearchValuePrepare Line: 166
   Module: Kernel::System::ITSMConfigItem::XML::XMLExportSearchValuePrepare Line: 132
   Module: Kernel::Output::HTML::Layout::KIX4OTRSITSMConfigManagement::_ExportXMLSearchDataPrepare Line: 900
   Module: Kernel::Output::HTML::Layout::KIX4OTRSITSMConfigManagement::KIXSideBarAssignedConfigItemsTable Line: 188
   Module: Kernel::Output::HTML::KIXSidebar::LinkedCIs::Run Line: 66
   Module: Kernel::Output::HTML::Layout::KIX4OTRS::AgentKIXSidebar Line: 538
   Module: Kernel::Modules::AgentTicketZoom::MaskAgentZoom Line: 862
   Module: Kernel::Modules::AgentTicketZoom::Run Line: 521
   Module: Kernel::System::Web::InterfaceAgent::Run Line: 1054
   Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_index_2epl::handler Line: 54
   Module: (eval) (v1.99) Line: 204
   Module: ModPerl::RegistryCooker::run (v1.99) Line: 204
   Module: ModPerl::RegistryCooker::default_handler (v1.99) Line: 170
   Module: ModPerl::Registry::handler (v1.99) Line: 31

And when I tried to open the created ticket using the pop message

I get the other error message:
[Tue Jun 20 09:42:59 2017] [error] Can't use string ("2") as a HASH ref while "strict refs" in use at /opt/otrs/KIX4OTRS/Kernel/Modules/AgentTicketZoom.pm line 946.\n

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #27 am: 20.06.2017 10:44:28 »
Attached is popup message when ticket was created.

Rico Ullmann

  • Gast
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #28 am: 20.06.2017 11:47:53 »
Have you installed any third party packages?

Regards

BenI

  • Newbie
  • Beiträge: 25
Re: Navigation Menu Items Not Functioning on Index Page
« Antwort #29 am: 20.06.2017 12:02:07 »
Yep. Attached is pics with list of packages installed.

Tags: