Autor Thema: Abhängigkeit perl-JSON-XS fehlt  (Gelesen 210 mal)

ostaehr

  • Newbie
  • Beiträge: 49
Abhängigkeit perl-JSON-XS fehlt
« am: 03.01.2017 10:40:29 »
Hallo,
nach einer frischen Installation Kix und Kixpro meldet das Apache-Errorlog
Message: Can't locate JSON/XS.pm in @INC (@INC contains: .......
Das Paket perl-JSON-XS ist nicht installiert, da es in den Abhängigkeiten wohl fehlt.
Grüße,
Olli
EDIT: Betriebssystem ist CentOS 7, aktuelle Kix Pakete aus dem Repo

Richard Leis

  • Global Moderator
  • Beiträge: 141
Re: Abhängigkeit perl-JSON-XS fehlt
« Antwort #1 am: 06.01.2017 14:53:21 »
Hallo Olli,

vielen Dank für den Hinweis.
Scheinbar werden hier die zusätzlichen Betriebssystem Pakete nicht mit installiert.
Kannst du mal das CheckModules Skript (<KIX-Home> ./bin/kix.CheckModules.pl) ausführen und mir die Ausgabe posten?

Falls noch nicht geschehen, kannst du das Paket manuell aus CPAN installieren. Dazu erst CPAN installieren:
yum install cpanUnd dann:
cpan json
Viele Grüße

Richard

ostaehr

  • Newbie
  • Beiträge: 49
Re: Abhängigkeit perl-JSON-XS fehlt
« Antwort #2 am: 06.01.2017 15:39:33 »
Hi,
klar, kein Problem, und offenbar fehlt noch was.
bin/kix.CheckModules.pl
   o Data::Compare..................Not installed! (Optional - Required to track SysConfig changes.)
yum install perl-Data-Compare
dann passt es
bin/kix.CheckModules.pl
   o Data::Compare..................ok (v1.25)
Ihr solltet also für CentOS 7 die Pakete perl-Data-Compare und perl-JSON-XS in die rpm-Abhängigkeit einbauen, denn die sind ja ohne CPAN verfügbar (was mir deutlich lieber ist :-)
Schöne Grüße,
Olli

Richard Leis

  • Global Moderator
  • Beiträge: 141
Re: Abhängigkeit perl-JSON-XS fehlt
« Antwort #3 am: 09.01.2017 08:16:58 »
Hallo Olli,

viele Dank für den Hinweis, ich gebe das an die Entwicklungsabteilung weiter.

Viele Grüße

Richard