Autor Thema: Kein "Weiter" Button in customer.pl (Kundenmenü)  (Gelesen 346 mal)

kixusr1

  • Newbie
  • Beiträge: 21
Hallo,
aktuell (kix_16.0.6) besteht ein Problem beim Kundenmenü wenn mehrere CustomID's vergeben sind.

Aktueller Zustand:
  • /customer.pl aufrufen
  • Einloggen
  • Neues Ticket erstellen
  • Die Liste mit verfügbaren CustomerID's erscheint
  • Kein Submit/Weiter Button verfügbar
  • -> Ticket erstellen unmöglich
Erwartet:
Weiter Button bei Schritt 5. Vergleiche Anhang 2 und 3.
= button mit input type submit



Zusatzinformationen:
Authentifizierung/Daten des Kundenbenutzers kommen aus dem LDAP:
       Map => ....  [ 'UserCustomerIDs',    'CustomerIDs',  'wbemPath',                     1, 0, 'var', '', 0 ], ...


=> Wenn ein Benutzer nur einer CustomerID zugeordnet ist, erscheint der Editor sofort im Benutzermenü. Im Agentenmenü funktioniert auch alles.
=> Wenn ein Benutzer mehreren CustomerID's zugeordnet ist, erscheint der Editor nicht im Benutzermenü, also ist keine Ticketerstellung möglich. Im Agentenmenü funktioniert alles.

Workaround:
Editor kann durch manuelles aufrufen der untenstehenden URL aufgerufen werden. Das ist aber keine Lösung für den Produktiveinsatz.

/customer.pl?Action=CustomerTicketMessage;SelectedCustomerID=INSERTIDHERE;DefaultSet=


Falls noch Fragen offen sind, oder Details fehlen bitte einfach bei mir melden.
Danke! :)

Beatrice Müller

  • Global Moderator
  • Beiträge: 100
Re: Kein "Weiter" Button in customer.pl (Kundenmenü)
« Antwort #1 am: 24.08.2016 13:27:54 »
Hallo,

wir konnten den Sachverhalt nachstellen und haben den Bug an unsere Entwicklungsabteilung weiter gegeben.
Er wird an dieser Stelle klassifiziert und qualifiziert.
Bei Bestätigung der Bugmeldung wird dafür, bei vertretbarem Aufwand, ein Fix in den nächsten Releasezyklus mit eingeplant.

Viele Grüße
Beatrice

Beatrice Müller

  • Global Moderator
  • Beiträge: 100
Re: Kein "Weiter" Button in customer.pl (Kundenmenü)
« Antwort #2 am: 29.08.2016 16:01:00 »
Der Fehler wird im nächsten Release behoben sein.

kixusr1

  • Newbie
  • Beiträge: 21
Re: Kein "Weiter" Button in customer.pl (Kundenmenü)
« Antwort #3 am: 29.08.2016 16:38:15 »
Super, danke!