Autor Thema: KIX4OTRS 8.0.23 - Paket nicht korrekt installiert. Bitte erneut installieren.  (Gelesen 98 mal)

mage

  • Gast
Hallo,
nach dem Update von KIX4OTRS 8.0.21 auf 8.0.23 taucht nun in der Paket-Verwaltung von OTRS die Meldung "KIX4OTRS 8.0.23 - Paket nicht korrekt installiert. Bitte erneut installieren." auf.Ein erneutes installieren über "Paket erneut installieren" hat keinen Effekt, die Version von OTRS selbst und KIXCore wurden nicht geändert, da laut Voraussetzungen (XML) die OTRS Version 5.0.29 und KIXCore 5.0.19 passen sollten. Testweise wurde dennoch KIXCore 5.0.20 installiert, die Fehlermeldung von KIX4OTRS bleibt jedoch bestehen. Die notwendigen Schritte (Rebuild Config, Delete Cache, CacheCleanup) wurden jeweils durchgeführt.
Sofern man die Fehlermeldung anklickt, erfährt man dass COPYING-GPL3 nicht installiert wäre, alle anderen Dateien scheinen ok zu sein.
Desweiteren ist nach dem Update auf KIX4OTRS 8.0.23 die Textbox beispielsweise bei einem neuen Telefon- oder E-Mailticket sehr stark nach links verschoben, unabhängig von der Kombination mit KIXCore 5.0.19 oder 5.0.20.
Sind diese beiden Probleme bekannt bzw. bereits in der Fehlerbeseitigung?
Danke

Martin Jäger

  • Global Moderator
  • Beiträge: 111
Hallo mage,
die Problematik der verschobenen Textbox ist bereits bekannt.Dies kann mittels einer Anpassung der Datei "/opt/kix/KIX4OTRS/var/httpd/htdocs/skins/Agent/default/css/KIX4OTRS.Default.css" behoben werden.
In dieser Datei müssten folgende Zeilen auskommentiert werden:fieldset.TableLike > .RichTextField {
 margin-left: 170px;}

Damit sollte die Ausrichtung der Textbox wieder an der richtigen Stelle stehen. :)


Die Problematik des nicht korrekt installierten KIX4OTRS-Paketes konnte ich bis dato selbst nicht nachstellen.
Hättest du hierzu ein paar mehr Informationen für mich?
Wissenswert wären folgende Punkte:
  • Verwendetes Betriebssystem
  • Verwendetes DBMS
  • Übersicht der installierten Zusatzpakete

Könntest du mir außerdem verraten, ob du das Update des Paketes über die Konsole oder über die Paketverwaltung im Frontend durchgeführt hast?


Viele Grüße,

Martin

mage

  • Gast
Hallo Martin,
vielen Dank für deine Antwort.
Es ist CentOS 7.6.1810 und MariaDB 5.5.60 im Einsatz. Neben KIX4OTRS und KIXCore ist nur noch das FAQ-Paket installiert. Das Update habe ich über die Paketverwaltung im Frontend durchgeführt.
Danke!

Martin Jäger

  • Global Moderator
  • Beiträge: 111
Hallo mage,

könntest du versuchen, das KIX4OTRS-Paket über die Konsole zu installieren?
Dies geht über den Befehl
  • sudo -u <Web-User> /opt/otrs/bin/otrs.Console.pl Admin::Package::Upgrade <absoluter_Pfad_zum_Paket>/KIX4OTRS-8.0.23.opm
Sollte die Installation fehlschlagen, wird auf der Konsole ein entsprechender Fehler ausgegeben.
Könntest du mir die entsprechende Fehlerausgabe zukommen lassen, sollte eine solche Meldung erscheinen?

Viele Grüße,
Martin

mage

  • Gast
Hallo Martin,
leider hat es über die Konsole nicht funktioniert. Ich habe das Update daher erneut über die Paketverwaltung im Frontend installiert.Ich habe die genannte Datei COPYING-GPL3 aus der Fehlermeldung einfach mal heruntergeladen und in das OTRS Hauptverzeichnis gelegt (danach Rechte gesetzt), damit verschwindet die Fehlermeldung und die Paketverwaltung ist zufrieden! Nur falls jemand mal das gleiche "Problem" haben sollte.

Tags: