Autor Thema: Which version of otrs framework is using kix2017?  (Gelesen 479 mal)

Nilufar

  • Newbie
  • Beiträge: 37
Hello! I wanted to extend some functionalities in kixdesk and found out some .opm packages to install but when i hit install button it gives me error message regarding not suitable framework for this particular package i'm installing. Here's question which version of otrs framework is using kix2017? and can i install different .opm packages to extend functionalities of the system?
Thank you in advance.

Richard Leis

  • Global Moderator
  • Beiträge: 232
Re: Which version of otrs framework is using kix2017?
« Antwort #1 am: 16.05.2018 13:04:41 »
Hello Nilufar,

OTRS 5 was just the base of the first version of KIX17.
The further development of KIX17 is independent from the OTRS framework.
The framework version of KIX17 is 17.x.x. That's why you get errors when you try to install OTRS packages.
To install your packages you would have to adjust their framework version. But due to the indepenency of the developments it is not sure that those packages work as intended in KIX17.

Best regards

Richard