Autor Thema: Problem mit "run as root"  (Gelesen 1212 mal)

Krouch

  • Newbie
  • Beiträge: 8
Problem mit "run as root"
« am: 22.05.2019 08:14:13 »
Guten Morgen,
ich erhalte folgende Fehlermeldung im kix.log:
[Wed May 22 07:01:24 2019][Error][Kernel::System::Daemon::DaemonModules::BaseTaskWorker::_HandleError][56] There was an error executing Execute() in Kernel::System::Console::Command::Maint::SupportData::CollectAsynchronous: Error: You cannot run kix.Console.pl as root. Please run it as the apache user or with the help of su:Da ich einen Windows Server nutze habe ich mittlerweile herausgefunden, dass ich dies (der Fehler war auch bei anderen Prozessen vorhanden) mit dem Parameter "--allow-root" beheben kann.->https://forum.kixdesk.com/index.php?topic=2515.0
Bei dem o.g. Fehler ist dies allerdings nicht möglich, da der Eintrag in den Cronjobs nicht änderbar ist (mit einem Schloss versehen).

Wie kann ich das Problem auf Windows Ebene lösen?

GrußThomas

Krouch

  • Newbie
  • Beiträge: 8
Re: Problem mit "run as root"
« Antwort #1 am: 22.05.2019 15:56:38 »
Hallo zusammen,
gibt es eigentlich einen Grund, warum man hier recht oft ignoriert wird?
- Sind meine Fragen zu "einfach"?
- Dürfen hier nur KIX Profis nachfragen?- Sind nur Linux User anwesend die nix von Windows halten?

Sorry dass ich so direkt frage, aber irgendwie kommt es mir so vor :(

f.niehus

  • Newbie
  • Beiträge: 66
Re: Problem mit "run as root"
« Antwort #2 am: 23.05.2019 09:09:18 »
Ich glaube, "Geduld" ist das Zauberwort...
Hier hängt nicht jeder täglich mehrmals ab, sodass es auch mal dauern kann, bis es eine Antwort gibt. Darüber hinaus ist der Betrieb unter Windows auch eher exotisch. Also nimm es nicht persönlich.

Mein Arbeitgeber ist zwar auch zu 100% "Windowsverhaftet", aber für die eine oder andere Geschichte habe ich trotzdem Linux platzieren können, weil ich dem jeweiligen Werkzeug eine schmerzfreie Umgebung bieten möchte. Vielleicht solltest Du es doch mal mit Linux probieren. In Bezug auf die Konfiguration von KIX ist das nicht unbedingt Raketentechnik. Muss ja nicht gleich ein eigenes System sein; klappt vielleicht auch mit dem WLS...




Martin Jäger

  • Newbie
  • Beiträge: 163
Re: Problem mit "run as root"
« Antwort #3 am: 05.06.2019 14:34:44 »
Hallo Thomas,
du kannst den Parameter "--allow-root" über folgende Ergänzung in der Config.pm hinzufügen:$Self->{'Daemon::SchedulerCronTaskManager::Task'}->{'SupportDataCollectAsynchronous'} =  {
  'Function' => 'Execute',
  'MaximumParallelInstances' => '1',
  'Module' => 'Kernel::System::Console::Command::Maint::SupportData::CollectAsynchronous',
  'Params' => ['--allow-root'],
  'Schedule' => '1 * * * *',
  'TaskName' => 'SupportDataCollectAsynchronous'
};

Nach dem Hinzufügen in der Config.pm ( zu finden unter: <InstallationsverzeichnisKIX>/kix/Kernel/Config.pm ) solltest du bei der Betrachtung
des SysConfig-Schlüssels "SupportDataCollectAsynchronous" den Parameter "--allow-root" nun mit sehen.


Viele Grüße,
Martin



Krouch

  • Newbie
  • Beiträge: 8
Re: Problem mit "run as root"
« Antwort #4 am: 07.06.2019 08:12:08 »
Guten Morgen Martin,
vielen Dank, das hat prima funktioniert :).
GrußThomas

Tags: windows installer