Autor Thema: KIX Applikationsserver startet nicht nach Installation mit Server 2012R2  (Gelesen 6571 mal)

bwewer

  • Newbie
  • Beiträge: 6
Hallo,

ich habe die neuste Version von KIX installiert und der KIX-Applikationsserver läst sich nicht starten (Fehler 1067: der Prozess wurde unerwartet beendet)
Installation:
Windows Server 2012R2
Net Framework 3.5
ActivePerl 5.22.1
MS SQL Server 2014
ODBC SQL 13


In der appservice.err.log steht auch Can't open perl script "C:\Perl/site/bin/plackup": No such file or directory

Wenn KIX Agent Interface aufgerufen wird kommt die Meldung: HTTP-Fehler 404.3 - Not Found

wer kann hier helfen?

vielen dank im vorraus
Berthold

Danny Bochmann

  • Newbie
  • Beiträge: 458
Hallo bwewer,

bitte halte dich exakt an die Anleitung zur nstallation unter Windows Server (https://www.kixdesk.com/de/kix-windows-installation.html).
Einzige Ausnahme ist an dieser Stelle Windows Server 2016, da bei diesem zusätzlich manuell das .Net Framework 3.5 Installiert werden muss.

VG
Danny

bwewer

  • Newbie
  • Beiträge: 6
Hallo Danny,
habe alles nach der Anleitung installiert und bekommen immer noch den Fehler: Can't open perl script "C:\Perl/site/bin/plackup": No such file or directory
VGBerthold

Danny Bochmann

  • Newbie
  • Beiträge: 458
Hallo bwewer,

nach deinem ersten Post hast du auf deiner Maschine ein ActivePerl 5.22.1 installiert.
Laut unserer Installationsanleitung wird allerdings ein ActivePerl 5.22 vorausgesetzt (https://www.kixdesk.com/de/kix-windows-installation.html).

Bei Verwendung einer anderen Version kommt es genau zu dem von dir genannten Fehler, dass der Perlscript nicht gefunden werden kann.
Bitte installiere das genannte ActivePerl und teste es erneut.
Beachte allerdings das dadurch eine komplette Neuinstallation notwendig wird.

Die notwendigen Schritte findest du unter https://forum.kixdesk.com/index.php?topic=1099.msg3506#msg3506

VG
Danny

bwewer

  • Newbie
  • Beiträge: 6
Hallo Danny,
gibt es irgendwo noch eine MSI Datei von ActivePerl 5.22.0? Im Internet finde ich keinen download mehr.
VGBerthold

Danny Bochmann

  • Newbie
  • Beiträge: 458
Hallo bwewer,

ich habe noch einmal eine Windowsinstanz mit einem KIX installiert.
Dazu habe ich folgende Schritte durchgeführt:
Windows installiert
Windowskennwort vergeben
Gasterweiterung installiert
.Net Framework 3.5 Installiert
ActivePerl 5.22.1 installiert
SQL Server 2017 Express installiert
SQL Server Management Studio installiert
ein Datenbank-Nutzer für KIX angelegt
eine leere Datenbank (kix17) für KIX angelegt
KIX 17.4.0 installiert


Bitte entschuldige meine Aussage, dass es nur mit der Version 5.22 von Active Perl funktioniert.
In meiner Testinstanz funktionierte auch die Version 5.22.1


VG
Danny

bwewer

  • Newbie
  • Beiträge: 6
Hallo Danny,

auch auf einer neuen VMware mit 2012R2 und genau der Installationsanleitung kann am Ende der Dienst KIX-Applikationsserver nichtgestartet werden.

Was mache ich den falsch?
VGBerthold

gross.an

  • Gast
Hallo,


ich habe auch die Installation wie oben ausgeführt und am Ende lässt sich der Dienst nicht starten.


Gruß

Danny Bochmann

  • Newbie
  • Beiträge: 458
Hallo @gross-an,
Hallo @ bwewer,

habt ihr eine Fehlermeldung um den Fehler einkreisen zu können?

VG
Danny

bwewer

  • Newbie
  • Beiträge: 6
Hallo,
in der appservice.err.log steht folgendes:Can't open perl script "C:\Perl/site/bin/plackup": No such file or directory
Die beiden kix log Dateien habe ich hinzugefügt.
VGBerthold

Danny Bochmann

  • Newbie
  • Beiträge: 458
Hallo bwewer,

du hast scheinbar ein Problem mit deinem Proxy:
  • ppm install failed: 500 Can't connect to :8080 (ftp://proxy:8080;http=proxy:8080;https=proxy)
Er muss aber zwingend die benötigten Pakete herunterladen können während der Installation.
Bitte prüfe dahingehend deine Konfiguration.

VG
Danny

bwewer

  • Newbie
  • Beiträge: 6
Mit folgender Systemvariable läuft es jetzt:

http_proxy=http://username:password@proxy.example.org:8080[/font]
[/font]
[/font]

Tags: windows installer