Autor Thema: CustomerUser per PostmasterFilter  (Gelesen 1073 mal)

alexander.ritz

  • Newbie
  • Beiträge: 34
CustomerUser per PostmasterFilter
« am: 21.02.2018 09:30:59 »
Guten Morgen!


In Anlehnung an das Thema https://forum.kixdesk.com/index.php?topic=495.msg1796#msg1796 mein Problem.


Wir haben für bestimmte automatisierte Nachrichten von Kundensystemen ein eigenes Postfach eingerichtet, in welches Fehlermeldungen eingehen. Absender dieser Fehlermeldungen ist jedoch immer eine donotreply@domain.com Adresse, so dass diese nicht für die Kundenzuordnung herangezogen werden kann.


In der Betreffzeile der E-Mail ist jedoch immer die Kundennummer des Kunden enthalten. Diese kann ich auch im PostmasterFilter per RegEx aus der Betreffzeile auslesen und als "X-KIX-CustomerNo" setzen. Das funktioniert so weit, das Ticket wird danach im Kunden selbst dargestellt.


Die E-Mail Adresse des CustomerUser ist im Body der E-Mail enthalten. Diese wird dann mit einer zweiten PostmasterFilter Regel per RegEx ausgelesen und auf "X-KIX-CustomerUser" gesetzt. Und genau das ist der Punkt, der nicht korrekt funktioniert.


Nachdem ein entsprechendes Ticket durch den Mailabruf erstellt wurde steht im Ticket selbst unter "Verknüpfte Objekte" bei Personen in den Feldern "Vorname" und "Nachname" der Eintrag "Person nicht gefunden: ausgelesene E-Mail Adresse".


Wie kann ich die Zuweisung zum CustomerUser hinbekommen?


Vielen Dank
Alexander Ritz


ostaehr

  • Newbie
  • Beiträge: 68
Re: CustomerUser per PostmasterFilter
« Antwort #1 am: 22.02.2018 08:06:36 »
Moin,
ich vermute mal, dass der Header From bei der Ticketerstellung ausgelesen und zugewiesen (bzw. eben nicht) wird. Den From kann man im Postmasterfilter ja leider nicht ändern. Das ginge aber notfalls in einem vorgelagerten Procmail.
Was steht denn in der Historie, welche Mailadresse bei der Erstellung verarbeitet wird? Die Noreply oder die im X-KIX-CustomerUser gesetzte?
VG Olli

alexander.ritz

  • Newbie
  • Beiträge: 34
Re: CustomerUser per PostmasterFilter
« Antwort #2 am: 22.02.2018 08:38:32 »
Guten Morgen,


bei der Prüfung der Tickethistorie ist mir aufgefallen, dass der RegEx die E-Mail Adresse des CustomerUser mit einem anhängenden Leerzeichen ausgibt. Damit ist eine Zuordnung nicht möglich. Nach einer kleinen Anpassung der Ursprungsmail und des RegEx funktioniert das jetzt wie gewünscht.


Danke.
Alexander Ritz


Tags: