Installation fails on Ubuntu 18.04 on MySQL

Begonnen von David Smith, 17.09.2018 02:36:37

⏪ vorheriges - nächstes ⏩

David Smith

Can anyone help please?  I hope this is the right place to submit about installation issues.
Pre-existing installation of MySQL on the server.  KIX installed with three commandsexport KIXMYSQL_USER=root
export KIXMYSQL_PASSWORD=<MySQL root password>
apt-get install kix-mysql kix

When it failed the first time, I created new MYSQL user root2 with same privileges as root and redid
export KIXMYSQL_USER=root2
export KIXMYSQL_PASSWORD=<root2 new password>
apt-get install kix-mysql kix

Failed in the same way.  Output of the apt command shows it is not using environmental variable KIXMYSQL_USER root2 but default MySQL user root, and no password submitted
Truncated output of apt install kix-mysql kix

installing framework
+ KIX_HOME=/opt/kix
+ SQLFILES=kix-schema.mysql.sql kix-initial_insert.mysql.sql kix-schema-post.mys                                                                             ql.sql
+ create_db debian ObFuScAtED
+ OSTYPE=debian
+ [ -z  ]
+ [ -n  ]
+ MYSQL_CONF_DIR=/etc/mysql/conf.d/
+ [ -d /etc/mysql/mysql.conf.d/ ]
+ MYSQL_CONF_DIR=/etc/mysql/mysql.conf.d/
+ wc -l
+ which ss
+ [ 1 -ne 0 ]
+ wc -l
+ grep mysql
+ ss -a
+ [ 2 -eq 0 ]
+ wc -l
+ mysql -uroot -e SHOW DATABASES LIKE 'kix17'
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
+ wc -l
+ mysql -uroot -e SELECT user FROM mysql.user WHERE user = 'kix'
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
+ tail -1
+ mysql -uroot --vertical --skip-column-names -e SHOW VARIABLES LIKE 'innodb_log                                                                             _file_size'
There's nothing in either folder /opt/kix17/var/log or /opt/kix/var/log except a folder Daemon I had to chmod o+xr to view, and that was empty.

Many thanks for any assistance anyone can provide with this.  I hope the issue isn't caused by using Ubuntu 18.04

David Smith

Found the fix - perform install as root, not as user with sudo.  It would seem that executing "sudo apt install kix-mysql kix" does not read the variables set with export.  Thankfully, I had root access to my online instance (I'm not sure all providers allow that out-of-the-box).  Performing the install as root worked perfectly.
Minor gripe.  After installation, I find the file /etc/apache2/sites-available/kix.conf exists there, and not in ../conf-available As soon as installation was complete, I wanted to give it a subdomain on my server and enable SSL with Let's Encrypt certbot, and so wanted to set a VirtualHost in sites-available/kix.conf and the pre-existing conf file does not allow (easily) for the addition of <VirtualHost *:80> And so, I moved kix.conf from sites-available to conf-available, activated it (a2enconf kix.conf) and created a new kix.conf in sites-available, copied from 000-default.conf and tweaked.
All works (but I'm a bit puzzled why it still gets served from www.mydomain.com/kix/index.pl as well as kix.mydomain.com/kix/index.pl but this is not the place to ask)